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FlowMaster   

Bentley FlowMaster is an easy-to-use, Windows-based program that aids civil engineers with the 
design and analysis of pipes, ditches, open channels, weirs, and more.  

Bentley FlowMaster computes flows, water velocities, depths and pressures based on several 
well-known formulas: Darcy-Weisbach, Manning's, Kutter's, and Hazen-Williams. It also utilizes 
the HEC-22 methodology to perform pavement drainage and inlet flow calculations.  

Bentley FlowMaster lets you solve for a variable you select, computing the solution from the 
parameters you provide. The program will also calculate rating tables, and will plot curves and 
cross sections. These graphs and reports can then be viewed on the screen, copied to the 
Windows clipboard, saved to a file, or printed on any standard printer.  

These tutorials provide step-by-step instructions for creating a project, entering data in a 
worksheet, and generating reports.  

The purpose of this section is to provide step-by-step tutorials to get you 
familiar with some of the features and capabilities of Bentley FlowMaster. The 
tutorials serve as a means to get you started exploring and using the software.  

Note:  You should follow these tutorials in sequence.  

If you need help within the program, press F1 to access the context-sensitive 
online help.  

Tutorial 1—Creating a New Project  

Data is entered and calculated in a worksheet. There are different worksheets for various 
structure types, because of the differing input and output data that is required for each.  

Worksheets are contained within an Bentley FlowMaster project. A project holds global 
information such as Project Engineer, Project Date, Project Location (the location where the 
project files are stored on your computer), and any Notes that go along with the project.  

The project is also associated with a unit system (FlexUnits). The unit system defines the units 
and display precision used in the project. Upon project creation, the default unit system is used, 
but this can be modified and saved for use on future projects.  

1. Start Bentley FlowMaster by double-clicking the shortcut on your desktop or by 
clicking the Bentley FlowMaster command from the Start menu. 

2. When Bentley FlowMaster opens, the welcome dialog box appears. Click the 
Create New Project button. 
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3. The main window opens, with the new project loaded. 

 

4. Click File > Save As. The Save As dialog box opens. 
5. Choose the directory to which the file will be saved and type MyTutorial1 as the 

name for the project file. 

Note:  We recommend you name the tutorial files you are using differently than any 
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other files in your program directory, so you don't overwrite pre-existing files.  

6. Now, enter some global project information. Click File > Properties.  
7. In the Project Properties dialog box, note the types of information. 

The Project Date field should already contain today's date (this information is 
retrieved from the Windows system calendar and clock—click the down-arrow 
button to select a different date by using a calendar). Project File Name contains 
the path to the directory where the project is saved.  

8. Enter the following information in the Project Properties dialog box: 
o Enter your name in the Project Engineer field. 
o Enter Tutorial Project in the Project Notes field.  
o If you want your company name to appear on the bottom of all reports 

associated with the project, enter the company name in the Project 
Company field.  

o If you want your company's logo to appear on the bottom of all reports 
associated with the project, click in the Company Logo field, then click 
the Ellipses button and select your company's logo image file.  

o Click OK. 

 

9. Click File > New > Worksheet. 
10. In the Create New Worksheet dialog box, ensure that Open Channels is 

highlighted in the Categories pane, then click Trapezoidal Channel. 
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11. Click OK. 
12. In the Trapezoidal Channel Worksheet dialog box, select Discharge in the Solve 

For drop-down list. 
13. Select Manning Formula in the Friction Method drop-down list. 



5 | P a g e  
 

 

14. In the Roughness Coefficient field, click the Ellipsis (...) button to open the 
Materials library.  

a. Expand the tree containing all of the available material libraries. 
b. Expand the HMI Material Library item to see the available materials 

within the library. 
c. Click Flood plain, cultivated to highlight it. 

Note that the lower section of the Materials dialog box is updated with the 
data that is associated with this material.  

d. Click OK; the Materials dialog box closes and a roughness coefficient of 
0.035 displays in the Roughness Coefficient field. 

 Click each of the other input fields in turn and enter the data contained in 
the following table into the appropriate input fields: 

Table 2-1: Input Data for Trapezoidal Worksheet (Tutorial 1) 

Attribute:  Value:  

Channel Slope  0.004500 ft/ft  

Normal Depth  2.30 ft  

Left Side Slope  0.50 H:V  

Right Side Slope  0.75 H:V  



6 | P a g e  
 

Bottom Width  5.00 ft  

The calculated discharge should be 53.21 ft3/sec.  

Note:  After you enter the last data into a field (Bottom Width, for example), you 
have to click in another field or click the Solve button to get the Discharge to 
refresh and update.  

 Save the project by clicking File > Save As. 
 Enter MyTutorial2 in the File name field, then click Save. 
 If needed, close any open dialog boxes. 

 

 

Class 2—Gradually Varied Flow Analysis  

For free-surface flow, depth rarely remains the same throughout the length of a channel or pipe. 
Gradually varied flow analysis lets you calculate the downstream depth from the length of the 
channel and the upstream depth, or to calculate the upstream depth from the length of the 
channel and the downstream depth.  

This tutorial is based on the project that was created in Tutorial 1—Creating a New Project.  
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1. If necessary, open the MyTutorial2 project file that you saved at the end of 
Tutorial1, and, in the Project Explorer, double-click the Trapezoidal Channel 
item to open the worksheet containing the channel you defined in Tutorial 1. 

2. In the Trapezoidal Channel Worksheet dialog box, click the Gradually Varied 
Flow tab. 

 

a. If needed, click the Direction drop-down list and select Given 
Downstream. 

This drop-down list lets you choose whether you are solving for upstream 
depth (when Given Downstream is selected) or downstream depth (when 
Given Upstream is selected).  

b. Click each of the other input fields in turn and enter the data contained in 
the following table into the appropriate input fields: 

Table 2-2: Input Data for Gradually Varied Flow Analysis (Tutorial 2) 

Attribute  Value  

Downstream Depth  3.0 ft  

Length  100 ft  

Number of Steps  5  



8 | P a g e  
 

c. Click Solve. The calculated downstream depth should be 2.74 ft.  

 

3. View the profile of the gradually varied flow analysis: Click Analysis > GVF 
Profile. 
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4. Save the project by clicking File > Save As. 
5. Enter MyTutorial3 in the File name field, and click Save. 
6. If needed, close any open dialog boxes. 

Class 3—Results Reporting  

Bentley FlowMaster provides a number of methods of generating reports from your calculated 
results. This tutorial introduces you to these methods.  

This tutorial is based on the project that was used in Tutorial 2—Gradually Varied Flow 
Analysis.  

1. If necessary, open the MyTutorial3 project file that you saved at the end of 
Tutorial 2, and, in the Project Explorer, double-click the Trapezoidal Channel 
item to open the worksheet containing the channel you defined in Tutorial 2. 

2. Click Analysis > Detailed Report. 
3. In the Generic Report Setup dialog box, change the default report title then click 

OK, or click OK to accept the default report title "Worksheet for Trapezoidal 
Channel." 

4. The Print Preview dialog box opens, displaying the report as it would appear if 
printed. 
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Note the information supplied in the report: Project Information, Input Data, 
Results, GVF Input Data, and GVF Output Data.  

5. Close the Print Preview dialog box. 
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6. Click Analysis > Tabular Reports > Channels > Trapezoidal. 

 

7. The Report Table dialog box that opens presents all calculation messages, notes, 
input data, and results for all of the trapezoidal channel worksheets within the 
project; in this case, just one. 

This report is useful for comparing multiple worksheets of the same type. If you 
want to print this report, begin by clicking the Print Preview button.  

8. Close the Report Table dialog box. 
9. Click Analysis > Cross Section. 

Note:  If Analysis > Cross Section is dimmed, click the Solve button, then try the 
menu item again.  

10. In the Cross Section Setup dialog box, enter Trapezoidal Channel as the Report 
Title, and click OK. 
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11. The Cross Section dialog box displays a cross section diagram defined by the 
trapezoidal channel worksheet. 

You can print the cross section by using the Print Preview button, then clicking 
the Print button in the Print Preview window.  

 

12. To change the size of the diagram: 
a. Click the Options button. 
b. Select the Manual Scale check box. 
c. Enter new value in the Aspect Ratio field, such as 3, and click OK. The 

diagram changes to reflect the aspect ration you entered. 
d. Change the Aspect Ratio back to 1. 
e. Close the Cross Section dialog box. 

13. Bentley FlowMaster also lets you graph a range of results that are calculated from 
a range of values for a specified variable via the rating curves feature. 

a. If necessary, close any open Print and Print Preview dialog boxes and 
open the Trapezoidal Channel Worksheet dialog box. 

b. Click Analysis > Rating Curve. 
c. In the Rating Curve Setup dialog box, select Velocity in the Plot drop-

down list. This is the attribute for which a range of values will be 
calculated. 
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d. Select Channel Slope in the Vs. drop-down list; this sets the attribute 
against which the Plot attribute is calculated. 

e. Enter the information contained in the following table for the other fields 
in the Rating Curve Setup dialog box: 

 Minimum: 0.0030 ft/ft 
 Maximum: 0.0060 ft/ft 
 Increment: 0.0005 ft/ft 

f. Click OK. The Rating Curve dialog box opens, showing a graph of the 
velocity at each of the slopes in the range that is specified by the values 
you entered. 

 

14. You can change practically any aspect of the graph's appearance by clicking the 
Chart Options button. 
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a. Experiment with the various settings available to you. To create the 3D 
chart shown here:  
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b. Click Chart Options > 3D. 
c. Select the 3 Dimensions check box. 
d. Set the 3D % to 90. 
e. Click the Walls tab. 
f. Click the Bottom tab, then click Color. 
g. Set the bottom color (in the example it has an Red, Green, Blue (RGB) 

value of 0, 255, 255). 
h. Click the Panel, then Background tabs. 
i. Click the Pattern, Gradient, then Format tabs. 
j. Select Vertical from the Direction drop-down list. 
k. Click the Colors tab. 
l. Click Start. 
m. Click Custom and set an RGB value of 255, 215, 0. 
n. Click OK > OK to close the color dialog boxes. 
o. Click End. 
p. Select white from the Color Editor dialog box (RGB of 255, 255, 255). 
q. Click OK. 
r. In the Hatch Brush Editor dialog box, select the No Middle Color check 

box. 
s. Click OK, then Close. 
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15. You can print the chart by clicking the Print Preview button, then clicking the 
Print button in the Print Preview window, or redefine the rating curve settings by 
clicking the Define Rating Curve button. 

16. Save the project, then close all the open windows. 
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